Vulnérabilité dans ProFTPd

ProFTPd vous permet de monter un serveur FTP au sein d'un environnement Linux afin d'effectuer du transfert de fichiers via les protocoles FTP, SFTP ou FTPS.

Kingcope a découvert une vulnérabilité dans le paquet proftpd-dfsg, au niveau des modules mod_sftp et mod_sftp_pam qui ne valident pas correctement les entrées avant de faire des alloncations groupées. De ce fait, l'attaquant peut utiliser ce défaut afin de mener des attaques par déni de service contre le système sur lequel ProFTPd tourne.

  • Debian Squeeze : Problème corrigé dans la version 1.3.3a-6squeeze7.
  • Debian Wheezy : Problème corrigé dans la version 1.3.4a-5+deb7u1.

En ce qui concerne les distributions testing (Jessie) et unstable (Sid), ce problème sera corrigé prochainement.

cover-proftpd

Partagez cet article Partager sur Twitter Partager sur Facebook Partager sur Linkedin Partager sur Google+ Envoyer par mail

Florian B.

Consultant chez Délibérata le jour, blogueur pour IT-Connect la nuit, je souhaite partager mon expérience et mes découvertes au travers de mes articles. Généraliste avec une attirance particulière pour les solutions Microsoft et le scripting. Bonne lecture.

florian has 2458 posts and counting.See all posts by florian

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

 

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.