<!DOCTYPE html><html lang="fr-FR" prefix="og: https://ogp.me/ns#"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script>
			
		<meta name="viewport" content="width=device-width, initial-scale=1"/>
		<link rel="profile" href="https://gmpg.org/xfn/11" />
		<title>Détails des durcissements des sysctl sous Linux : sysctl système | Commandes et Système | IT-Connect</title><link rel="stylesheet" href="https://www.it-connect.fr/wp-content-itc/cache/min/1/78b58f3a929f454bb0dcacc5d0465711.css" media="all" data-minify="1"/>

		<!-- All in One SEO Pro 4.1.0.2 -->
		<meta name="description" content="Nous allons dans cet article nous intéresser aux durcissements du noyau proposés par le guide de configuration de l\\\&#39;ANSSI a travers les sysctl système Linux."/>
		<meta name="keywords" content="linux,sécurité,sysctl,commandes et système,sécurité informatique"/>
		<link rel="canonical" href="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/"/>
		<meta property="og:site_name" content="IT-Connect"/>
		<meta property="og:type" content="article"/>
		<meta property="og:title" content="Détails des durcissements des sysctl sous Linux : sysctl système | Commandes et Système | IT-Connect"/>
		<meta property="og:description" content="Nous allons dans cet article nous intéresser aux durcissements du noyau proposés par le guide de configuration de l\\\&#39;ANSSI a travers les sysctl système Linux."/>
		<meta property="og:url" content="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/"/>
		<meta property="fb:app_id" content="350496265080636"/>
		<meta property="fb:admins" content="100002824629857"/>
		<meta property="og:image" content="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg"/>
		<meta property="og:image:secure_url" content="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg"/>
		<meta property="og:image:width" content="800"/>
		<meta property="og:image:height" content="445"/>
		<meta property="article:published_time" content="2021-05-12T08:00:39Z"/>
		<meta property="article:modified_time" content="2021-05-12T17:13:22Z"/>
		<meta property="article:publisher" content="https://www.facebook.com/it.connect.fr/"/>
		<meta name="twitter:card" content="summary"/>
		<meta name="twitter:site" content="@itconnect_fr"/>
		<meta name="twitter:domain" content="www.it-connect.fr"/>
		<meta name="twitter:title" content="Détails des durcissements des sysctl sous Linux : sysctl système | Commandes et Système | IT-Connect"/>
		<meta name="twitter:description" content="Nous allons dans cet article nous intéresser aux durcissements du noyau proposés par le guide de configuration de l\\\&#39;ANSSI a travers les sysctl système Linux."/>
		<meta name="twitter:image" content="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg"/>
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.it-connect.fr\/#website","url":"https:\/\/www.it-connect.fr\/","name":"IT-Connect","publisher":{"@id":"https:\/\/www.it-connect.fr\/#organization"}},{"@type":"Organization","@id":"https:\/\/www.it-connect.fr\/#organization","name":"IT-Connect","url":"https:\/\/www.it-connect.fr\/","logo":{"@type":"ImageObject","@id":"https:\/\/www.it-connect.fr\/#organizationLogo","url":"https:\/\/www.it-connect.fr\/wp-content-itc\/uploads\/2020\/11\/Logo-FavIcon-IT-Connect-2017.png","width":"600","height":"600"},"image":{"@id":"https:\/\/www.it-connect.fr\/#organizationLogo"},"sameAs":["https:\/\/www.facebook.com\/it.connect.fr\/","https:\/\/twitter.com\/itconnect_fr","https:\/\/www.instagram.com\/it_connect.fr\/","https:\/\/www.youtube.com\/channel\/UCIJTq0nGrgkGMy1xJL_YppQ","https:\/\/www.linkedin.com\/company\/it-connect-fr"]},{"@type":"BreadcrumbList","@id":"https:\/\/www.it-connect.fr\/details-durcissement-sysctl-systeme-linux\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.it-connect.fr\/#listItem","position":"1","item":{"@id":"https:\/\/www.it-connect.fr\/#item","name":"Accueil","description":"IT-Connect : tutoriels, cours, tests, actualit\u00e9 sur l'administration syst\u00e8me et r\u00e9seau (Windows, Linux, PowerShell...), le Cloud, la s\u00e9curit\u00e9 et la domotique.","url":"https:\/\/www.it-connect.fr\/"},"nextItem":"https:\/\/www.it-connect.fr\/details-durcissement-sysctl-systeme-linux\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.it-connect.fr\/details-durcissement-sysctl-systeme-linux\/#listItem","position":"2","item":{"@id":"https:\/\/www.it-connect.fr\/details-durcissement-sysctl-systeme-linux\/#item","name":"D\u00e9tails des durcissements des sysctl sous Linux : sysctl syst\u00e8me","description":"Nous allons dans cet article nous int\u00e9resser aux durcissements du noyau propos\u00e9s par le guide de configuration de l\\\\\\'ANSSI a travers les sysctl syst\u00e8me Linux.","url":"https:\/\/www.it-connect.fr\/details-durcissement-sysctl-systeme-linux\/"},"previousItem":"https:\/\/www.it-connect.fr\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.it-connect.fr\/author\/mickael\/#author","url":"https:\/\/www.it-connect.fr\/author\/mickael\/","name":"Mickael Dorigny","image":{"@type":"ImageObject","@id":"https:\/\/www.it-connect.fr\/details-durcissement-sysctl-systeme-linux\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/f61eee1ad118f37c6a77111e7eb22ced?s=96&d=mm&r=g","width":"96","height":"96","caption":"Mickael Dorigny"},"sameAs":["https:\/\/www.instagram.com\/it_connect.fr\/","https:\/\/www.youtube.com\/channel\/UCIJTq0nGrgkGMy1xJL_YppQ","https:\/\/www.linkedin.com\/company\/it-connect-fr"]}]}
		</script>
		<!-- All in One SEO Pro -->

<link rel="dns-prefetch" href="//fonts.googleapis.com"/>
<link rel="dns-prefetch" href="//ajax.googleapis.com"/>
<link rel="dns-prefetch" href="//secure.gravatar.com"/>
<link rel="dns-prefetch" href="//matomo.it-connect.fr"/>
<link rel="dns-prefetch" href="//dvr.impactify.io"/>
<link rel="dns-prefetch" href="//adservice.google.com"/>
<link rel="dns-prefetch" href="//pagead2.googlesyndication.com"/>
<link rel="dns-prefetch" href="//ssl.google-analytics.com"/>
<link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"/>
<link rel="dns-prefetch" href="//img.youtube.com"/>
<link href="https://fonts.gstatic.com" crossorigin="" rel="preconnect"/>
<link rel="alternate" type="application/rss+xml" title="IT-Connect » Flux" href="https://www.it-connect.fr/feed/"/>
<link rel="alternate" type="application/rss+xml" title="IT-Connect » Flux des commentaires" href="https://www.it-connect.fr/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="IT-Connect » Détails des durcissements des sysctl sous Linux : sysctl système Flux des commentaires" href="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/feed/"/>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	





<style id="learndash-front-inline-css" type="text/css">
		.learndash-wrapper .ld-focus .ld-focus-main .ld-focus-content {
			max-width: 768px;
		}
		
</style>




<style id="colormag_style-inline-css" type="text/css">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</style>

<link rel="stylesheet" id="colormag_googlefonts-css" href="//fonts.googleapis.com/css?family=PT+Sans%3Aregular%7COpen+Sans%3A600%2Cregular&amp;subset=latin&amp;display=swap" type="text/css" media="all"/>

<script type="text/javascript" src="https://www.it-connect.fr/wp-includes/js/jquery/jquery.min.js" id="jquery-core-js"></script>


<!--[if lte IE 8]>
<script type='text/javascript' src='https://www.it-connect.fr/wp-content-itc/themes/colormag-pro/js/html5shiv.min.js' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://www.it-connect.fr/wp-json/"/><link rel="alternate" type="application/json" href="https://www.it-connect.fr/wp-json/wp/v2/posts/42305"/>
<link rel="shortlink" href="https://www.it-connect.fr/?p=42305"/>
<style type="text/css">div#toc_container {background: #f9f9f9;border: 1px solid #003A6C;width: 96%;}div#toc_container p.toc_title {color: #003A6C;}div#toc_container p.toc_title a,div#toc_container ul.toc_list a {color: #494949;}div#toc_container p.toc_title a:hover,div#toc_container ul.toc_list a:hover {color: #0091C7;}div#toc_container p.toc_title a:hover,div#toc_container ul.toc_list a:hover {color: #0091C7;}div#toc_container p.toc_title a:visited,div#toc_container ul.toc_list a:visited {color: #8b8b8b;}</style><script type="text/javascript">
  var _paq = _paq || [];

<!-- Debut - Obligation CNIL -->
_paq.push([function() {
    var self = this;
    function getOriginalVisitorCookieTimeout() {
        var now = new Date(),
        nowTs = Math.round(now.getTime() / 1000),
        visitorInfo = self.getVisitorInfo();
        var createTs = parseInt(visitorInfo[2]);
        var cookieTimeout = 33696000; // 13 mois en secondes
        var originalTimeout = createTs + cookieTimeout - nowTs;
        return originalTimeout;
    }
    this.setVisitorCookieTimeout( getOriginalVisitorCookieTimeout() );
}]);
<!-- Fin - Obligation CNIL -->

  /* tracker methods like 'setCustomDimension' should be called before 'trackPageView' */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u='//matomo.it-connect.fr/';
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script><link rel="pingback" href="https://www.it-connect.fr/xmlrpc.php"/><link rel="icon" href="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/cropped-favicon-2017-v2-32x32.png" sizes="32x32"/>
<link rel="icon" href="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/cropped-favicon-2017-v2-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon" href="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/cropped-favicon-2017-v2-180x180.png"/>
<meta name="msapplication-TileImage" content="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/cropped-favicon-2017-v2-270x270.png"/>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="text/javascript">var ezouid = "1";</script><base href="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 122228;
var ezdomain = 'it-connect.fr';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":122228,"domain_test_group":20210301,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"581154e8-bf6e-4887-72b9-26bcd1d8463a","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":139773,"response_time_orig":5,"serverid":"54.165.25.19:22034","state":"VA","t_epoch":1621333965,"template_id":120,"time_on_site_visit":0,"url":"https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/","user_id":0,"word_count":3972,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_122228=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["581154e8-bf6e-4887-72b9-26bcd1d8463a", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>

<body class="post-template-default single single-post postid-42305 single-format-standard custom-background wp-custom-logo wp-embed-responsive right-sidebar box-layout" itemscope="itemscope" itemtype="http://schema.org/Blog" dir="ltr">

		<div id="page" class="hfeed site">
				<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
				<header id="masthead" class="site-header clearfix " role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
				<div id="header-text-nav-container" class="clearfix">
		
			<div class="news-bar">
				<div class="inner-wrap clearfix">
					
		<div class="date-in-header">
			18/05/2021		</div>

		
		<div class="social-links clearfix">
			<ul>
				<li><a href="https://www.facebook.com/it.connect.fr/" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/ITConnect_fr" target="_blank"><i class="fa fa-twitter"></i></a></li><li><a href="https://www.instagram.com/it_connect.fr/?hl=fr" target="_blank"><i class="fa fa-instagram"></i></a></li><li><a href="https://www.youtube.com/channel/UCIJTq0nGrgkGMy1xJL_YppQ" target="_blank"><i class="fa fa-youtube"></i></a></li><li><a href="https://www.linkedin.com/company/it-connect-fr" target="_blank"><i class="fa fa-linkedin"></i></a></li>			</ul>
		</div><!-- .social-links -->
						</div>
			</div>

			
		<div class="inner-wrap">
			<div id="header-text-nav-wrap" class="clearfix">

				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://www.it-connect.fr/" class="custom-logo-link" rel="home"><img width="397" height="85" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20397%2085&#39;%3E%3C/svg%3E" class="custom-logo" alt="IT-Connect" srcset="" data-lazy-sizes="(max-width: 397px) 100vw, 397px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/IT-Connect_Flat_072017_Small_v2.png"/><noscript><img width="397" height="85" src="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/IT-Connect_Flat_072017_Small_v2.png" class="custom-logo" alt="IT-Connect" srcset="" sizes="(max-width: 397px) 100vw, 397px" /></noscript></a>						</div><!-- #header-logo-image -->
						
					<div id="header-text" class="screen-reader-text">
													<h3 id="site-title" itemprop="headline">
								<a href="https://www.it-connect.fr/" title="IT-Connect" rel="home">IT-Connect</a>
							</h3>
						
											</div><!-- #header-text -->
				</div><!-- #header-left-section -->

				<div id="header-right-section">
											<div id="header-right-sidebar" class="clearfix">
							<aside id="text-42" class="widget widget_text clearfix">			<div class="textwidget"><p class="header-text">Plate-forme de cours sur l’administration systèmes et réseau pour les professionnels de l’informatique</p>
</div>
		</aside>						</div>
										</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->
		</div><!-- .inner-wrap -->

		
			<nav id="site-navigation" class="main-navigation clearfix" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
				<div class="inner-wrap clearfix">
					
						<div class="home-icon">
							<a href="https://www.it-connect.fr/" title="IT-Connect">
								<i class="fa fa-home"></i>
							</a>
						</div>
					
											<div class="search-random-icons-container">
															<div class="top-search-wrap">
									<i class="fa fa-search search-top"></i>
									<div class="search-form-top">
										
<form action="https://www.it-connect.fr/" class="search-form searchform clearfix" method="get" role="search">

	<div class="search-wrap">
		<input type="search" class="s field" name="s" value="" placeholder="Recherche"/>

		<button class="search-icon" type="submit"></button>
	</div>

</form><!-- .searchform -->
									</div>
								</div>
													</div>
					
					<p class="menu-toggle"></p>
					<div class="menu-primary-container"><ul id="menu-menu-full" class="menu"><li id="menu-item-13412" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-13412"><a href="https://www.it-connect.fr/cours-tutoriels/">Cours – Tutoriels</a>
<ul class="sub-menu">
	<li id="menu-item-16021" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-16021"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/">Administration Systèmes</a>
	<ul class="sub-menu">
		<li id="menu-item-13431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13431"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/">Windows Server</a>
		<ul class="sub-menu">
			<li id="menu-item-13437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13437"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/gpo-windows/">Stratégie de groupe</a></li>
			<li id="menu-item-13438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13438"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/systeme/">Système</a></li>
			<li id="menu-item-20072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20072"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/deploiement-mdt-wds/">Déploiement MDT – WDS</a></li>
			<li id="menu-item-13439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13439"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/dfs-dfsr/">DFS – DFSR</a></li>
			<li id="menu-item-13442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13442"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/windows-active-directory/">Active Directory</a></li>
			<li id="menu-item-13445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13445"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-server/wsus/">WSUS</a></li>
		</ul>
</li>
		<li id="menu-item-13430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13430"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-client/">Windows Client</a>
		<ul class="sub-menu">
			<li id="menu-item-13432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13432"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-client/logiciels/">Logiciels</a></li>
			<li id="menu-item-13436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13436"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/windows-client/astuces/">Astuces</a></li>
		</ul>
</li>
		<li id="menu-item-13422" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-13422"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/">Linux</a>
		<ul class="sub-menu">
			<li id="menu-item-13450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13450"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/services/">Services</a></li>
			<li id="menu-item-13447" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13447"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/linux-systeme/">Commandes et Système</a></li>
			<li id="menu-item-13452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13452"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/ssh/">SSH</a></li>
		</ul>
</li>
		<li id="menu-item-13423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13423"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/virtualisation/">Virtualisation</a>
		<ul class="sub-menu">
			<li id="menu-item-13459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13459"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/virtualisation/hyper-v/">Hyper-V</a></li>
			<li id="menu-item-13455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13455"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/virtualisation/vmware/">VMware</a></li>
		</ul>
</li>
		<li id="menu-item-13425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13425"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/serveur-web/">Serveur Web</a>
		<ul class="sub-menu">
			<li id="menu-item-13475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13475"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/serveur-web/microsoft-iis/">Microsoft IIS</a></li>
			<li id="menu-item-13476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13476"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/serveur-web/apache/">Apache</a></li>
		</ul>
</li>
		<li id="menu-item-13426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13426"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/stockage/">Stockage</a>
		<ul class="sub-menu">
			<li id="menu-item-13483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13483"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/stockage/nas/">NAS</a></li>
			<li id="menu-item-13486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13486"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/stockage/cloud/">Cloud</a></li>
			<li id="menu-item-13490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13490"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/stockage/bdd/">Base de données</a></li>
		</ul>
</li>
		<li id="menu-item-13427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13427"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/scripting/">Scripting</a>
		<ul class="sub-menu">
			<li id="menu-item-13493" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13493"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/scripting/bash/">Bash</a></li>
			<li id="menu-item-13492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13492"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/scripting/batch/">Batch</a></li>
			<li id="menu-item-13494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13494"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/scripting/powershell/">Powershell</a></li>
		</ul>
</li>
		<li id="menu-item-13429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13429"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/autres/">Autres</a>
		<ul class="sub-menu">
			<li id="menu-item-27449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27449"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/autres/office-365/">Office 365</a></li>
			<li id="menu-item-13473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13473"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/autres/sauvegarde/">Sauvegarde</a></li>
			<li id="menu-item-13554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13554"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/autres/mobile/">Android – iOS</a></li>
			<li id="menu-item-13428" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13428"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/autres/developpement-web/">Développement Web</a></li>
			<li id="menu-item-13500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13500"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/autres/wordpress/">WordPress</a></li>
		</ul>
</li>
	</ul>
</li>
	<li id="menu-item-16020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16020"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/">Administration Réseau</a>
	<ul class="sub-menu">
		<li id="menu-item-13467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13467"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/pare-feu/">Pare-Feu</a>
		<ul class="sub-menu">
			<li id="menu-item-13468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13468"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/pare-feu/ipcop/">IPCOP</a></li>
			<li id="menu-item-13471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13471"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/pare-feu/netfilter/">Netfilter</a></li>
			<li id="menu-item-13470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13470"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/pare-feu/pfsense/">pfSense</a></li>
			<li id="menu-item-13469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13469"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/pare-feu/zeroshell/">ZeroShell</a></li>
		</ul>
</li>
		<li id="menu-item-13465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13465"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/supervision/">Supervision</a></li>
		<li id="menu-item-14839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14839"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/cisco/">Cisco</a></li>
		<li id="menu-item-14840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14840"><a href="https://www.it-connect.fr/cours-tutoriels/administration-reseau/hp/">HP</a></li>
	</ul>
</li>
	<li id="menu-item-20073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20073"><a href="https://www.it-connect.fr/cours-tutoriels/referencement-et-web/">Référencement et Web</a>
	<ul class="sub-menu">
		<li id="menu-item-20074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20074"><a href="https://www.it-connect.fr/cours-tutoriels/referencement-et-web/internet/">Internet</a></li>
		<li id="menu-item-20075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20075"><a href="https://www.it-connect.fr/cours-tutoriels/referencement-et-web/seo/">SEO</a></li>
	</ul>
</li>
	<li id="menu-item-27893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27893"><a href="https://www.it-connect.fr/tutoriels-domotique/">Domotique</a></li>
	<li id="menu-item-33409" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33409"><a href="https://www.it-connect.fr/cours-tutoriels/securite-informatique/">Sécurité</a></li>
</ul>
</li>
<li id="menu-item-26194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26194"><a href="https://www.it-connect.fr/cours-it-gratuits/">Cours IT</a></li>
<li id="menu-item-14844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14844"><a href="https://www.it-connect.fr/actualites/">Actualités</a>
<ul class="sub-menu">
	<li id="menu-item-14880" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14880"><a href="https://www.it-connect.fr/actualites/entreprise/">Entreprise</a></li>
	<li id="menu-item-14854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14854"><a href="https://www.it-connect.fr/actualites/dsi-experience/">DSI Experience</a></li>
	<li id="menu-item-15515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15515"><a href="https://www.it-connect.fr/actualites/actu-securite/">Sécurité</a></li>
	<li id="menu-item-14881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14881"><a href="https://www.it-connect.fr/actualites/actu-internet/">Web</a></li>
	<li id="menu-item-14883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14883"><a href="https://www.it-connect.fr/actualites/actu-logiciel-os/">Logiciel – OS</a></li>
	<li id="menu-item-14872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14872"><a href="https://www.it-connect.fr/actualites/actu-materiel/">Matériel</a></li>
	<li id="menu-item-14873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14873"><a href="https://www.it-connect.fr/actualites/reseaux-sociaux-actualites/">Réseaux sociaux</a></li>
	<li id="menu-item-14847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14847"><a href="https://www.it-connect.fr/actualites/actu-mobile/">Mobile</a></li>
</ul>
</li>
<li id="menu-item-14852" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14852"><a href="https://www.it-connect.fr/offres-demploi/">Emploi</a></li>
<li id="menu-item-30494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30494"><a href="https://www.it-connect.fr/bons-plans-high-tech/">Bons Plans</a></li>
<li id="menu-item-16101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16101"><a href="https://www.it-connect.fr/actualites/tests-materiel-logiciel/">Tests</a></li>
<li id="menu-item-31665" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31665"><a href="https://www.it-connect.fr/actualites/linksoftheweek/">#LinksOfTheWeek</a></li>
</ul></div>
				</div>
			</nav>

					</div><!-- #header-text-nav-container -->
				</header><!-- #masthead -->
				<div id="main" class="clearfix" role="main">
				<div class="inner-wrap clearfix">
		
		<!-- Intégration du fil d'ariane (1 ligne) -->
	<div class="breadcrumb-itc"><span><a title="IT-Connect" href="https://www.it-connect.fr" style="font-weight: bold; color: rgb(244, 141, 40);">IT-Connect</a></span> » <span><a href="https://www.it-connect.fr/cours-tutoriels/" title="Voir tous les articles de Cours - Tutoriels" class="ariane">Cours - Tutoriels</a></span> » <span><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/" title="Voir tous les articles de Administration Systèmes" class="ariane">Administration Systèmes</a></span> » <span><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/" title="Voir tous les articles de Linux" class="ariane">Linux</a></span> » <span><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/linux-systeme/" title="Voir tous les articles de Commandes et Système" class="ariane">Commandes et Système</a></span> » Détails des durcissements des sysctl sous Linux : sysctl système</div>	<br/>
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-42305" class="post-42305 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-systeme category-linux category-securite-informatique tag-linux tag-securite tag-sysctl" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost">
	
	
				<div class="featured-image" itemprop="image" itemtype="http://schema.org/ImageObject">
				<img width="800" height="445" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20800%20445&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg 800w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-550x306.jpg 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-150x83.jpg 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-768x427.jpg 768w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-160x89.jpg 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-50x28.jpg 50w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-800x445.jpg"/><noscript><img width="800" height="445" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-800x445.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg 800w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-550x306.jpg 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-150x83.jpg 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-768x427.jpg 768w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-160x89.jpg 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme-50x28.jpg 50w" sizes="(max-width: 800px) 100vw, 800px" /></noscript>					<meta itemprop="url" content="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg"/>
							</div>

			
	<div class="article-content clearfix">

		<div class="above-entry-meta"><span class="cat-links"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/linux-systeme/" rel="category tag">Commandes et Système</a> <a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/" style="background:#dd9f42" rel="category tag">Linux</a> <a href="https://www.it-connect.fr/cours-tutoriels/securite-informatique/" style="background:#b70000" rel="category tag">Sécurité Informatique</a> </span></div>
			<header class="entry-header">
				<h1 class="entry-title" itemprop="headline">
					Détails des durcissements des sysctl sous Linux : sysctl système				</h1>
			</header>

			<div class="below-entry-meta ">
			<span class="posted-on"><a href="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/" title="10:00" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2021-05-12T10:00:39+02:00" itemprop="datePublished">12/05/2021</time><time class="updated" datetime="2021-05-12T19:13:22+02:00" itemprop="dateModified">12/05/2021</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n" href="https://www.it-connect.fr/author/mickael/" title="Mickael Dorigny">
						Mickael Dorigny					</a>
				</span>
			</span>

			
							<span class="comments">
					<a href="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/#respond" itemprop="discussionURL"><i class="fa fa-comment"></i> Aucun commentaire</a>				</span>
				<span class="tag-links" itemprop="keywords"><i class="fa fa-tags"></i><a href="https://www.it-connect.fr/tag/linux/" rel="tag">Linux</a>, <a href="https://www.it-connect.fr/tag/securite/" rel="tag">Sécurité</a>, <a href="https://www.it-connect.fr/tag/sysctl/" rel="tag">Sysctl</a></span></div>
		<div class="entry-content clearfix" itemprop="articleBody">
			<div id="toc_container" class="no_bullets"><p class="toc_title">Sommaire</p><ul class="toc_list"><li><a href="#I_Presentation">I. Présentation</a></li><li><a href="#II_Comment_modifier_un_sysctl">II. Comment modifier un sysctl</a></li><li><a href="#III_Durcissement_des_sysctl_systeme_Linux">III. Durcissement des sysctl système Linux</a><ul><li><a href="#A_Desactivation_des_SysReq">A. Désactivation des SysReq</a></li><li><a href="#B_Interdire_les_core_dump_des_executables_setuid">B. Interdire les core dump des exécutables setuid</a></li><li><a href="#C_Dereferencement_des_liens_de_fichiers">C. Déréférencement des liens de fichiers</a></li><li><a href="#D_Activation_de_l_ASLR">D. Activation de l’ ASLR</a></li><li><a href="#E_Mappage_de_la_memoire_des_adresses_basses">E. Mappage de la mémoire des adresses basses</a></li><li><a href="#F_Espace_de_choix_plus_grand_pour_les_valeurs_de_PID">F. Espace de choix plus grand pour les valeurs de PID</a></li><li><a href="#G_Obfuscation_des_adresses_memoires_kernel">G. Obfuscation des adresses mémoires kernel</a></li><li><a href="#H_Restriction_dacces_au_buffer_dmesg">H. Restriction d’accès au buffer dmesg</a></li><li><a href="#I_Restreindre_lutilisation_du_sous-systeme_perf">I. Restreindre l’utilisation du sous-système perf</a></li></ul></li></ul></div>
<h2 class="md-end-block md-heading"><span id="I_Presentation"><span class="md-plain">I. Présentation</span></span></h2>
<p><span class="md-plain">Nous allons dans cet article nous intéresser <strong>aux durcissements du noyau proposés par le guide de configuration de l&#39;ANSSI à travers les <em>sysctl</em></strong><em>.</em> Les guides de bonnes pratiques et de configuration de l&#39;ANSSI sont pour la plupart très pertinents, mais il arrive qu&#39;ils manquent de détails et que la cohérence de certains durcissements puisse être difficile à appréhender. Je vais donc ici m&#39;efforcer de décortiquer les recommandations 22 et 23 du Guide <a href="https://www.ssi.gouv.fr/uploads/2016/01/linux_configuration-fr-v1.2.pdf" target="_blank" rel="noopener">Recommandation de configuration d&#39;un système GNU/Linux</a> de l&#39;ANSSI qui portent sur les paramétrages des <em>sysctl</em> réseau et système en vue du durcissement d&#39;un noyau <a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/">Linux</a>. Nous parlerons dans cet article des <em>sysctl</em> système et un prochain article portera sur les <em>sysctl</em> réseau.</span></p>
<p><span class="md-plain">J&#39;essaierai notamment de<strong> mettre en avant les implications en termes de sécurité et les attaques qu&#39;un durcissement permet d&#39;éviter</strong>, sans oublier les <strong>potentiels effets de bords</strong> si ceux-ci sont connus et les éventuelles questions qui restent en suspens après avoir tenté de creuser ce sujet.</span></p>
<p class="md-end-block md-p md-focus"><span class="md-plain md-expand">Sur les OS Linux, <strong><em>sysctl</em> est utilisé afin de consulter et modifier les paramètres du noyau</strong>, cela nous permet donc de configurer certains comportements du noyau comme la prise en compte de l&#39;IPv6 sur nos interfaces réseau ou l&#39;activation de l&#39;ASLR. Les paramètres utilisables sont ceux listés dans le répertoire <em>/proc/sys</em>. </span></p>
<blockquote>
<p class="md-end-block md-p md-focus"><span class="md-plain md-expand">On parle souvent de <em>sysctl</em> pour décrire une clé de configuration paramétrable par la commande <em>sysctl</em>. Ne soyez donc pas étonné de lire &#34;<em>On configure le sysctl </em><span role="presentation"><em>net.ipv4.ip_forward à 0</em>&#34; pour indiquer que la clé de configuration <em>net.ipv4.ip_forward</em> doit être définie à <em>0</em>, par exemple 😉</span></span></p>
</blockquote>
<p class="md-end-block md-p"><span class="md-plain">Pour les systèmes utilisant <em>systemd</em>, la configuration des <em>sysctl</em> se trouve dans <em>/etc/sysctl.d/</em></span><span class="md-pair-s "><em><span class="md-plain">.conf</span><span class="md-plain">, /usr/lib/sysctl.d/</span></em></span><span class="md-plain">.conf. et <em>/etc/sysctl.conf</em>.</span></p>
<p class="md-end-block md-p"><span class="md-plain">Attention, depuis récemment (2017) il se peut que certains systèmes utilisant <em>systemd</em> n&#39;appliquent plus les configurations <em>sysctl</em> indiquées dans <em>/etc/sysctl.conf</em>. Seuls les fichiers ayant une extensions <em>.conf</em> et situés dans les répertoires <em>/etc/sysctl.d</em> ou <em>/usr/lib/sysctl.d</em> sont appliqués.</span></p>
<p>➡ A lire également : <a href="https://www.it-connect.fr/details-durcissement-sysctl-reseau-linux/" target="_blank" rel="noopener">Détails des durcissements des sysctl sous Linux : sysctl réseau</a></p>
<h2 class="md-end-block md-heading"><span id="II_Comment_modifier_un_sysctl"><span class="md-plain">II. Comment modifier un sysctl</span></span></h2>
<p class="md-end-block md-p"><span class="md-plain">Il existe deux possibilités de modification d&#39;un <em>sysctl</em>, <strong>soit de façon temporaire</strong>, c&#39;est à dire valable jusqu&#39;au prochain redémarrage, <strong>soit de façon persistante</strong>, c&#39;est à dire qui persiste après un redémarrage.</span></p>
<p class="md-end-block md-p"><span class="md-plain">Pour modifier une configuration <em>sysctl</em> de façon temporaire, on peut modifier à chaud la valeur stockée dans le fichier correspondant au <em>sysctl</em> à modifier, par exemple : </span></p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation"># echo 1 &gt; /proc/sys/kernel/sysrq</span></pre>
<p class="md-end-block md-p"><span class="md-plain">Ou utiliser la commande <em>sysctl</em> pour faire cette même opération :</span></p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation"># sysctl -w kernel.sysrq=1</span></pre>
<p class="md-end-block md-p"><span class="md-plain">Pour modifier un <em>sysctl</em> de façon persistante, il faut aller modifier le fichier configuration (<em>/etc/sysctl.d/99-sysctl.con</em>f, ou autre fichier finissant par <em>.conf</em> dans le même dossier) et y modifier ou ajouter notre valeur pour le <em>sysctl</em> souhaité : </span></p>
<figure id="attachment_42313" aria-describedby="caption-attachment-42313" style="width: 612px" class="wp-caption aligncenter"><a href="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux.png"><img class="wp-image-42313 size-full" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20612%20218&#39;%3E%3C/svg%3E" alt="Modification persistante d&#39;une sysctl" width="612" height="218" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux.png 612w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-550x196.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-150x53.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-160x57.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-50x18.png 50w" data-lazy-sizes="(max-width: 612px) 100vw, 612px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux.png"/><noscript><img class="wp-image-42313 size-full" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux.png" alt="Modification persistante d'une sysctl" width="612" height="218" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux.png 612w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-550x196.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-150x53.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-160x57.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/modification-permanente-sysctl-linux-50x18.png 50w" sizes="(max-width: 612px) 100vw, 612px" /></noscript></a><figcaption id="caption-attachment-42313" class="wp-caption-text">Modification persistante d&#39;une sysctl</figcaption></figure>
<p class="md-end-block md-p"><span class="md-plain">Pour être techniquement plus précis, une configuration modifiant un <em>sysctl</em> est appelée clé. Ici la clé est donc <em>net.ipv4.conf.default.log_martians</em> et <em>0</em> est la valeur associée à cette clé.</span></p>
<p class="md-end-block md-heading"><span class="md-plain">Pour afficher l&#39;ensemble des <em>sysctl</em> actuellement utilisées et appliquées, la commande suivante est à utiliser : </span></p>
<pre class="md-end-block md-p"><span class="md-plain"># sysctl -a</span></pre>
<p>Enfin pour récupérer un <em>sysctl</em> précis, la commande suivante est à utiliser :</p>
<pre># sysctl -n net.ipv4.conf.eth1.log_martians</pre>
<h2 class="md-end-block md-heading"><span id="III_Durcissement_des_sysctl_systeme_Linux"><span class="md-plain">III. Durcissement des sysctl système Linux</span></span></h2>
<h3 class="md-end-block md-p"><span id="A_Desactivation_des_SysReq"><span class="md-pair-s"><span class="md-plain">A. Désactivation des SysReq</span></span></span></h3>
<p class="md-end-block md-p"><span class="md-plain">Les <em>SysReq </em>ou M<em>agic System Request Key</em> sont une fonctionnalité du noyau Linux permettant, <strong><em>via</em> une combinaison de touche réalisable à tout moment, de lancer des commandes bas niveau</strong>, par exemple afin de pouvoir redémarrer un système bloqué sans corrompre le système de fichiers ou tuer un programme paralysant les ressources du système. Parmi les actions réalisables :</span></p>
<ul>
<li>Déterminer le niveau de log de la console</li>
<li>Redémarrer l&#39;ordinateur reBoot</li>
<li>Redémarrer via kexec pour faire un crashdump Crashdump</li>
<li>Envoyer un signal de terminaison (SIGTERM) à tous les processus (sauf init) tErm</li>
<li>Tuer le processus qui consomme le plus de mémoire (via oom-killer)</li>
<li>Envoyer un signal de fin (SIGKILL, plus ferme que SIGTERM) à tous les processus (sauf init)</li>
<li>Tuer tous les processus de la console virtuelle courante.</li>
<li>Envoyer un signal de fin (SIGKILL, plus ferme que SIGTERM) à tous les processus (même init)</li>
<li>Afficher le contenu actuel de la mémoire Memory</li>
<li>Éteindre le systeme via APM Out</li>
<li>Afficher sur la console les registres et drapeaux actuels Print</li>
<li>Basculer la gestion du clavier de mode brute (raw) à XLATE</li>
<li>Synchroniser les disques (tente d&#39;écrire toutes les données non sauvegardées)</li>
<li>Afficher une liste des taches et <a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/virtualisation/autres-virtu/">autres</a> informations dans la console</li>
<li>Remonter les disques en lecture seule</li>
</ul>
<p>À noter que même si les SysReq sont activées, une partie seulement de ces actions sont réalisables dans la configuration par défaut. D&#39;<a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/serveur-web/autres-serveur-web/">autres</a> requièrent une configuration spécifique. <span class="md-plain"><strong>Cette combinaison de touche clavier doit être réalisée sur un terminal &#34;physique&#34;</strong>, entendez par là qu&#39;une connexion SSH ne sera pas suffisante, en théorie :).</span></p>
<p class="md-end-block md-p"><span class="md-plain">Il existe en effet une petite astuce permettant d&#39;exécuter des SysReq depuis une connexion distante, et cela en utilisant directement une fonctionnalité &#34;native&#34; de <em>sysctl,</em> le fichier <em>/proc/sysrq-trigger</em>. Si l&#39;on souhaite redémarrer le système par exemple, il faut envoyer l&#39;instruction &#34;b&#34;, et donc :</span></p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation">echo &#34;b&#34; &gt; /proc/sysrq-trigger</span></pre>
<p class="md-end-block md-p"><span class="md-plain">Ce fichier n&#39;est cependant modifiable que par l&#39;utilisateur <em>root</em> : </span></p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6c191f091e555d2c070d0005">[email&#160;protected]</a>:~$ ls -al /proc/sysrq-trigger</span>
<span role="presentation"> --w------- 1 root root 0 juil. 28  2018 /proc/sysrq-trigger</span></pre>
<p class="md-end-block md-p"><span class="md-plain">Pour gérer cela, il faut se rendre dans le fichier <em>/proc/sys/kernel/sysrq</em> ou utiliser la clé <em>kernel.sysrq</em> dans un fichier de configuration <em>sysctl.</em></span></p>
<p class="md-end-block md-p"><span class="md-plain">Positionner la valeur 1 permet d&#39;activer l&#39;utilisation des SysReq (valeur par défaut sur une majorité de systèmes), positionner la valeur <em>0</em> interdit toute utilisation des SysReq. Lorsque la valeur est autre que 0 ou 1, <strong>c&#39;est que certaines commandes sont autorisées, d&#39;autres non</strong>, à utiliser en connaissance de cause donc. À nouveau, comme <strong>cette fonctionnalité est très rarement utilisée, voir inconnue des sysadmins la plupart du temps</strong>, mieux vaut la désactiver :</span></p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation">kernel . sysrq = 0</span></pre>
<p class="md-end-block md-p"><span class="md-plain">L&#39;ANSSI recommande en effet de positionner la valeur de cette clé à 0 afin de désactiver totalement leur utilisation.<strong> On peut imaginer les effets de bords possibles grâce à ces commandes</strong>, notamment en ce qui concerne la possibilité de tuer des processus, afficher les registres CPU, démonter un système de fichier, redémarrer la machine, etc. À noter que <strong>le plus grand danger reste l&#39;exploitation de ces SysReq à partir d&#39;un terminal physique par un utilisateur non </strong></span> <span class="md-plain"><strong> privilégié</strong>, mais leur utilisation n&#39;est pas forcément restreinte au terminal physique comme je l&#39;ai indiqué précédemment. </span></p>
<p class="md-end-block md-p"><span class="md-plain">La frontière entre physique et virtuel s&#39;étant quelque peu estompée ces dernières années, j&#39;ignore par exemple si l&#39;on peut lancer des SysReq à partir d&#39;un clavier virtuel, dans le cas d&#39;un accès distant VNC, <em>via</em> une console d&#39;hyperviseur type <a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/virtualisation/vmware/">VMWare</a>/Proxmox, etc.</span></p>
<h3 class="md-end-block md-p"><span id="B_Interdire_les_core_dump_des_executables_setuid"><span class="md-pair-s"><span class="md-plain">B. Interdire les core dump des exécutables setuid</span></span></span></h3>
<p class="md-end-block md-p"><span class="md-plain">Par défaut,<b> le système va réaliser un <em>core dump</em> (extraction de la mémoire) des processus s&#39;arrêtant brusquement</b>, cela est notamment pratique pour du <em>debug,</em> avoir une photo à l&#39;instant du crash permet de voir quelles données ou actions ont potentiellement causé ce crash. </span></p>
<p class="md-end-block md-p"><span class="md-plain">Cependant, <strong>ces <em>dumps</em> sont exécutés par le kernel et écrits sur le système avec les droits de l&#39;utilisateur courant</strong> (celui ayant lancé la commande). Dans le cadre de l&#39;utilisation d&#39;un exécutable <em>setuid</em> ou <em>setgid,</em> l&#39;extraction mémoire contiendra les informations d&#39;un programme exécuté avec les droits d&#39;un autre utilisateur, probablement avec un plus haut niveau de privilège que l&#39;utilisateur courant ou <em>root,</em> mais sera écrit sur le système avec les droits de l&#39;utilisateur courant (non privilégié). Ainsi, <strong>des informations sensibles, permettant potentiellement une élévation de privilège, pourront se trouver dans ce type de fichier et lisible par l&#39;utilisateur courant</strong>.</span></p>
<p class="md-end-block md-p"><span class="md-plain">Afin de contrôler ce comportement, on peut utiliser la clé <em>fs.suid_dumpable</em> afin de ne pas produire de <em>core dump</em> pour les exécutables possédant un bit <em>setuid</em> ou <em>setgid.</em></span></p>
<pre><span role="presentation">fs.suid_dumpable = 0</span></pre>
<p class="md-end-block md-p"><span class="md-plain">L&#39;ANSSI recommande de passer la valeur de la clé <em>fs.suid_dumpable</em> à <em>0</em> pour désactiver tout<em> core dump</em> sur les exécutables possédant un bit <em>setuid</em> ou <em>setgid</em>, et ainsi <strong>éviter d&#39;éventuelles fuites de données sensibles concernant les attributs, les fichiers accédés ou d&#39;autres actions d&#39;un utilisateur privilégié</strong>.</span></p>
<h3 class="md-end-block md-p"><span id="C_Dereferencement_des_liens_de_fichiers"><span class="md-pair-s"><span class="md-plain">C. Déréférencement des liens de fichiers</span></span></span></h3>
<p>Une des vulnérabilités courantes sous Linux concernant les liens symboliques est le <strong><em>symlink-based time-of-check-time-of-use race</em> (ou<em> symlink race condition</em>)</strong>. Il s&#39;agit d&#39;un delta de temps entre le moment où un fichier est contrôlé (pour voir si les droits d&#39;accès sont suffisants) et celui où il est utilisé par un programme.</p>
<p>Pendant le laps de temps où ces deux opérations sont effectuées, <strong>un utilisateur malveillant peut créer un lien symbolique portant le nom de ce fichier et ainsi manipuler une partie de l&#39;exécution du programme</strong>, qui s&#39;exécute idéalement avec un plus haut niveau de privilège. Un exemple courant fourni comme explication est le suivant :</p>
<figure id="attachment_42397" aria-describedby="caption-attachment-42397" style="width: 800px" class="wp-caption aligncenter"><a href="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia.png"><img class="size-large wp-image-42397" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20800%20218&#39;%3E%3C/svg%3E" alt="Exemple d&#39;une attaque time-of-check to time-of-use - Wikipedia" width="800" height="218" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-800x218.png 800w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-550x150.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-150x41.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-768x209.png 768w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-160x44.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-50x14.png 50w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia.png 820w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-800x218.png"/><noscript><img class="size-large wp-image-42397" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-800x218.png" alt="Exemple d'une attaque time-of-check to time-of-use - Wikipedia" width="800" height="218" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-800x218.png 800w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-550x150.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-150x41.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-768x209.png 768w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-160x44.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia-50x14.png 50w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/symlink-toctou-wikipedia.png 820w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a><figcaption id="caption-attachment-42397" class="wp-caption-text">Exemple d&#39;une attaque time-of-check to time-of-use - Wikipedia</figcaption></figure>
<p>Dans cet exemple, le programme contrôle les permissions d&#39;un fichier <em>file</em> avec l&#39;instruction <em>access()</em> en C. Puis, dans un deuxième temps si les permissions le permettent, il va écrire dans ce fichier. Dans le cadre d&#39;une attaque, l&#39;attaquant va laisser le fichier tel quel pour la première opération (par exemple créer lui-même le fichier file en permission 777 pour que le programme constate qu&#39;il peut y écrire). Puis, il va remplacer ce fichier par un lien symbolique pointant vers <em>/etc/passwd</em>. Le programme s&#39;exécutant avec un haut niveau de privilège va alors exécuter sa deuxième instruction et écrire dans le fichier <em>file,</em> qui sera en réalité<em>/etc/passwd</em>.</p>
<p>Un très bon labo est mis à disposition sur ce Gitlab <a title="Lab Race Condition symlink" href="https://github.com/anjelikasah/Race-Condition-Seedsecurity" target="_blank" rel="noopener">Ranjelikasah/ace-Condition-Seedsecurity</a>,<strong> je vous le recommande si vous souhaitez expérimenter par vous-même</strong> 🙂</p>
<p>Ce type d&#39;attaque est notamment <strong>dangereuse sur les setuid/setgid</strong>, qui permettent d&#39;exécuter un binaire avec les droits <em>root</em> (ou d&#39;un autre utilisateur en fonction de leur configuration). C&#39;est pourquoi il est recommandé de durcir ces <em>sysctl</em> qui ont plusieurs effets concernant les liens symboliques et les setuid.</p>
<p>Concernant les <em>hardlinks</em> et<strong> pour un utilisateur système créant un lien</strong>, l&#39;une des conditions suivantes doit être remplie :</p>
<ul>
<li>l&#39;utilisateur peut seulement créer des liens vers des fichiers dont il est le propriétaire</li>
<li>l&#39;utilisateur doit avoir les droits d&#39;écriture et de lecture vers le fichier vers lequel souhaite créer un lien.</li>
</ul>
<figure id="attachment_42398" aria-describedby="caption-attachment-42398" style="width: 704px" class="wp-caption aligncenter"><a href="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink.png"><img class="size-full wp-image-42398" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20704%20238&#39;%3E%3C/svg%3E" alt="Démonstration sur l&#39;effet des durcissement sysctl sur la création des hardlinks" width="704" height="238" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink.png 704w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-550x186.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-150x51.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-160x54.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-50x17.png 50w" data-lazy-sizes="(max-width: 704px) 100vw, 704px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink.png"/><noscript><img class="size-full wp-image-42398" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink.png" alt="Démonstration sur l'effet des durcissement sysctl sur la création des hardlinks" width="704" height="238" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink.png 704w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-550x186.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-150x51.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-160x54.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/demo_durcissement_symlink-50x17.png 50w" sizes="(max-width: 704px) 100vw, 704px" /></noscript></a><figcaption id="caption-attachment-42398" class="wp-caption-text">Démonstration de l&#39;effet des durcissements sysctl sur la création des hardlinks</figcaption></figure>
<p>Concernant les <em>symlinks</em> et <strong>les processus qui sont amenés à suivre des liens symboliques</strong> vers des répertoires <em>world-writable</em> qui ont le <em>sticky bit</em> activé :</p>
<ul>
<li>le processus suivant le lien symbolique doit être le propriétaire du lien symbolique</li>
<li>le propriétaire du répertoire est également le propriétaire du lien symbolique.</li>
</ul>
<p>Si vous avez bien compris le fonctionnement de l&#39;attaque présentée, vous comprendrez rapidement quelle devient impossible si ces conditions sont imposées <em>via</em> le durcissement <em>sysctl</em> :</p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation">fs.protected_symlinks = 1</span>
<span role="presentation">fs.protected_hardlinks = 1</span></pre>
<p>Ce paramétrage permet en somme de durcir les conditions d&#39;utilisation des <em>symlinks </em>et des<em> hardlinks</em> afin de se protéger des différentes attaques permettant une élévation de privilège</p>
<h3 class="md-end-block md-p"><span id="D_Activation_de_l_ASLR"><span class="md-pair-s"><span class="md-plain">D. Activation de l’ ASLR</span></span></span></h3>
<p><span class="md-plain">L&#39;ASLR (<em>Address Space Layout Randomization</em>) est un <strong>mécanisme permettant de limiter les effets et de complexifier l&#39;exploitation des attaques de type <em>buffer overflow</em></strong> (dépassement de tampon). L&#39;objectif est ici de placer la zone de données dans la mémoire virtuelle de façon aléatoire, changeant ainsi sa position à chaque exécution.</span></p>
<blockquote>
<p class="md-end-block md-p"><span class="md-plain">L&#39;exploitation de <em>buffer overflow</em> consiste notamment à contrôler une partie des registres CPU afin de modifier le flux d&#39;exécution d&#39;un programme. Cela passe, entre autres, par le contrôle du registre EIP (<em>Extended Instruction Pointer</em>) qui permet d&#39;indiquer à quel <em>offset</em> (adresse mémoire) la prochaine instruction à exécuter se trouve. En contrôlant le registre EIP, l&#39;attaquant peut indiquer au programme de sauter à un <em>offset</em> précis et dont le contenu est sous son contrôle, notamment s&#39;il a réussi à injecter du code malveillant <em>(shellcode)</em> à cet endroit de la mémoire. En modifiant la répartition et le positionnement des instructions, de la pile <em>(stack),</em> du tas <em>(heap)</em> et autres, en mémoire, l&#39;attaquant n&#39;est plus en capacité de pointer vers son <em>shellcode</em> car celui-ci ne sera jamais au même endroit à chaque exécution.</span></p>
</blockquote>
<p class="md-end-block md-p"><span class="md-plain">Pour activer l&#39;ASLR, on peut utiliser la clé <em>kernel.randomize_va_space </em></span> <span class="md-plain"> et y positionner la valeur <em>2</em>, qui permet de positionner de façon </span> <span class="md-plain"> aléatoire (aka <em>randomiser</em> :/ ) la <em>stack</em> (pile), les pages CDSO (<em>virtual dynamic shared object</em>), la mémoire partagée et le segment de données (<em>data segment</em>), qui contient les variables globales et statiques initialisées par le programme. Positionner la valeur <em>1</em> aura le même effet, sauf pour le segment de données. La valeur <em>0</em> désactive l&#39;ASLR.</span></p>
<pre><span role="presentation">kernel.randomize_va_space = 2</span></pre>
<p class="md-end-block md-p"><span class="md-plain">Pour plus d&#39;information sur les <em>buffer overflow</em>, je vous oriente vers les très bons articles (en français) d&#39;0x0ff : </span></p>
<ul>
<li class="md-end-block md-p"><a title="BUFFER OVERFLOW &amp; GDB – PART 1" href="https://www.0x0ff.info/2015/buffer-overflow-gdb-part1/" target="_blank" rel="noopener"><span class="md-plain">BUFFER OVERFLOW &amp; GDB – PART 1</span></a></li>
<li><a title="BUFFER OVERFLOW &amp; GDB – PART 2" href="https://www.0x0ff.info/2015/buffer-overflow-gdb-part-2/" target="_blank" rel="noopener">BUFFER OVERFLOW &amp; GDB – PART 2</a></li>
</ul>
<h3 class="md-end-block md-p"><span id="E_Mappage_de_la_memoire_des_adresses_basses"><span class="md-pair-s"><span class="md-plain">E. Mappage de la mémoire des adresses basses</span></span></span></h3>
<p>Une vulnérabilité de type <em>NULL pointer dereference</em> est le fait pour un programme d&#39;utiliser un pointeur non initialisé (valant NULL) ou pointant vers une adresse mémoire inexistante (<span class="md-plain">0x00000000). De fait, lorsque ce programme utilisera ce pointeur dans ses instructions, cela causera un crash. Dans le contexte d&#39;exécution du noyau ou d&#39;un programme à haut niveau de privilège, <strong>le fait de déclencher intentionnellement l&#39;utilisation d&#39;un pointeur NULL par un attaquant lui permet de faire crasher le programme, voir le système</strong>.</span></p>
<p>Cependant, si l&#39;attaquant parvient à identifier l&#39;adresse mémoire du pointeur en question et à la manipuler pour y insérer les données de son choix avant qu&#39;elle ne soit utilisée activement par le noyau ou un programme à haut niveau de privilège, alors <strong>il pourra contrôler son utilisation dans le programme exécuté, menant à une potentielle élévation de privilège.</strong></p>
<blockquote>
<p class="md-end-block md-p"><span class="md-plain">En C, un pointeur est une variable qui permet de stocker non pas une valeur (&#34;ABC&#34; ou 12,28), mais une adresse mémoire. Lorsqu&#39;un programme démarre, le système lui alloue une zone mémoire dans laquelle il peut s&#39;organiser. Cette zone mémoire est constituée de &#34;cases&#34; de 8 bits (octets). Chacune de ces cases (appelées blocs) est identifiée par un numéro : son adresse. On peut alors accéder à une variable soit par son nom &#34;agePersonne&#34;, soit par l&#39;adresse du premier bloc alloué à la variable en question, c&#39;est-à-dire son pointeur.</span></p>
</blockquote>
<p class="md-end-block md-p">Il se trouve que le noyau a tendance à plutôt utiliser les adresses mémoires dites &#34;basses&#34;, si l&#39;attaquant parvient à manipuler les pointeurs visant des blocs d&#39;adresses mémoires &#34;basses&#34;, alors il a plus de chances de trouver un bloc d&#39;adresse qui sera ensuite utilisé par le noyau.</p>
<p class="md-end-block md-p"><span class="md-plain">La clé <em>vm.mmap_min_addr</em> est donc une constante <strong>qui permet d&#39;empêcher les utilisateurs non privilégiés de créer des mapping mémoires en dessous de cette adresse</strong>. Elle permet de définir l&#39;adresse minimale qu&#39;un processus n&#39;ayant pas les droits <em>root</em> peut mapper, adresse que nous allons rehausser par rapport à sa valeur par défaut (0) :</span></p>
<pre><span role="presentation">vm.mmap_min_addr = 65536</span></pre>
<p>Attention toutefois à bien tester le fonctionnement de vos programmes et applications avec ce paramètre avant de passer en production.</p>
<h3 class="md-end-block md-p"><span id="F_Espace_de_choix_plus_grand_pour_les_valeurs_de_PID"><span class="md-pair-s"><span class="md-plain">F. Espace de choix plus grand pour les valeurs de PID</span></span></span></h3>
<p>Sous Linux (et Windows), le PID (<em>Process IDentifier</em>) est <strong>un numéro unique assigné à un processus en <a href="https://www.it-connect.fr/cours-it-gratuits/">cours</a> d&#39;exécution</strong>. Il permet son identification parmi d&#39;autres processus pour leur gestion, par exemple lorsque l&#39;on utilise les commandes <em>ps</em> ou <em>kill</em>.</p>
<p>Comme pour les ports clients, <strong>les PID  sont en nombre limité sur un système</strong>. Il se peut donc que toute la plage de PID disponible soit saturée par un dysfonctionnement ou une attaque. Dès lors, <strong>aucun autre processus ne pourra être créé</strong>, car il n&#39;aura aucun PID à utiliser. L&#39;ANSSI recommande d&#39;élargir la plage du nombre de PID disponible sur un système afin d&#39;éviter ou de limiter de tels scénarios :</p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation">kernel.pid_max = 65536</span></pre>
<p class="md-end-block md-p"><span class="md-plain">Cette configuration permet donc de <strong>prévenir d&#39;une saturation de PID entrainant une impossibilité de créer de nouveau processus</strong>. Sur les systèmes 32 bits, la valeur max est de 32 768 alors que pour les systèmes 64 bits, elle est de 2^22 (4 194 304, ça fait beaucoup de processus). À noter toutefois que les PID sont &#34;recyclés&#34;, c&#39;est-à-dire que lorsqu&#39;un processus avec un certain PID se termine, ce PID peut être réutilisé plus tard par un autre processus. Ce durcissement vise donc à élargir le nombre de processus tournant simultanément sur votre système, ce qui ne sera le cas qu&#39;en cas d&#39;attaque ou pour des serveurs à très haute performance.</span></p>
<h3 class="md-end-block md-p"><span id="G_Obfuscation_des_adresses_memoires_kernel"><span class="md-plain">G. Obfuscation des adresses mémoires kernel</span></span></h3>
<p>Un attaquant qui cherche à compromettre un noyau en cours d&#39;exécution en écrasant les structures de données du noyau ou en forçant un <em>jump</em> (saut) vers un code de noyau spécifique doit, dans les deux cas, <strong>avoir une idée de l&#39;emplacement des objets cibles en mémoire</strong>. Des techniques comme l&#39;ASLR ont été créées dans l&#39;espoir de &#34;dissimuler&#34; cette information, mais cet effort est vain <strong>si le noyau divulgue des informations sur l&#39;endroit où il a été placé en mémoire</strong>. Il existe en effet plusieurs cas de figure où des adresses mémoires relatives au <em>kernel</em> peuvent être affichées (fuitées) vers l&#39;espace utilisateur, qui obtient alors des informations intéressantes sur les pointeurs à cibler dans le cadre d&#39;une attaque.</p>
<p>L&#39;ANSSI recommande de paramétrer la directive suivante à <em>1</em> afin que, <strong>dans certains cas</strong>, <strong>les adresses mémoires relatives au noyau affichées par un programme soit dissimulées</strong> (remplacées par des 0) :</p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation"> kernel.kptr_restrict = 1</span></pre>
<p>Attention toutefois, <strong>cette dissimulation n&#39;est effective uniquement si le programme utilise la notation <em>%pK</em></strong> (au lieu de <em>%p</em> pour un pointeur &#34;normal&#34;). C&#39;est-à-dire que le développeur a marqué le pointeur vers une adresse noyau comme tel et indique donc au système que l&#39;information doit être protégée. Dans le cas où un programme ne respecte pas cette bonne pratique, le durcissement au niveau du <em>sysctl</em> est inutile.</p>
<p>Enfin, si l&#39;utilisateur possède la <em>capabilities</em> CAP_SYSLOG dans le contexte d&#39;exécution du programme, les adresses mémoire kernel seront affichées normalement (paramétrez la <em>sysctl</em> à <em>2</em> si vous souhaitez éviter ce cas de figure).</p>
<h3 class="md-end-block md-p"><span id="H_Restriction_dacces_au_buffer_dmesg"><span class="md-pair-s"><span class="md-plain">H. Restriction d’accès au buffer <em>dmesg</em></span></span></span></h3>
<p>Sous Linux, <b>la commande </b><em style="font-weight: bold;">dmesg</em><b> permet de voir les journaux (plus précisément la mémoire tampon des messages) relatifs au </b><em style="font-weight: bold;">kernel,</em> par exemple ceux créés par les <em>drivers,</em> lors du démarrage du système ou au branchement d&#39;un nouveau périphérique. Ces messages sont ensuite stockés dans le fichier <em>/var/log/messages</em>.</p>
<p>L&#39;ANSSI recommande de configurer le <em>sysctl</em> suivant à <em>1</em> afin de n&#39;autoriser que les utilisateurs privilégiés à consulter ce type d&#39;information <em>via</em> la commande <em>dmesg</em> :</p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation"> kernel.d</span>mesg_restrict <span role="presentation">= 1</span></pre>
<p>L&#39;objectif est ici de <strong>dissimuler les informations relatives aux journaux du noyau de la vue des utilisateurs</strong>, ceux-ci peuvent en effet dans certains cas contenir des informations sensibles pouvant être utilisées dans le cadre de futures attaques.</p>
<p>Voici un exemple de l&#39;utilisation de la commande <em>dmesg</em> par un utilisateur non privilégié avec le paramétrage à 1, puis à 0 :</p>
<figure id="attachment_42659" aria-describedby="caption-attachment-42659" style="width: 800px" class="wp-caption aligncenter"><a href="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo.png"><img class="size-full wp-image-42659" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20800%20388&#39;%3E%3C/svg%3E" alt="Effet de la sysctl kernel.dmesg_restrict" width="800" height="388" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo.png 800w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-550x267.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-150x73.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-768x372.png 768w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-160x78.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-50x24.png 50w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo.png"/><noscript><img class="size-full wp-image-42659" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo.png" alt="Effet de la sysctl kernel.dmesg_restrict" width="800" height="388" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo.png 800w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-550x267.png 550w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-150x73.png 150w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-768x372.png 768w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-160x78.png 160w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/dmesg-sysctl-demo-50x24.png 50w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a><figcaption id="caption-attachment-42659" class="wp-caption-text">Effet de la sysctl kernel.dmesg_restrict</figcaption></figure>
<h3 class="md-end-block md-p"><span id="I_Restreindre_lutilisation_du_sous-systeme_perf"><span class="md-pair-s"><span class="md-plain">I. Restreindre l’utilisation du sous-système perf</span></span></span></h3>
<p>Sous Linux, le sous-système <em>perf</em> est une commande très complète et puissante qui permet de mesurer les performances d&#39;un programme ou du système. Il réalise ces mesures en étant au plus proche de <em>l&#39;hardware,</em> ce qui nécessite un niveau de privilège élevé.</p>
<p>L&#39;ANSSI recommande le paramétrage à 2 de la <em>sysctl</em> suivante afin de limiter l&#39;accès des utilisateurs non privilégiés à cette commande :</p>
<pre class="md-fences md-end-block ty-contain-cm modeLoaded" lang="" spellcheck="false"><span role="presentation">kernel.perf_event_paranoid = 2</span></pre>
<p>Ainsi, un utilisateur non privilégié ne sera pas en mesure d&#39;utiliser cette commande, qui peut notamment impacter les performances du système. Ce paramétrage est effectif sauf si l&#39;utilisateur en question possède la <em>capabilities</em> CAP_SYS_ADMIN.</p>
<p>Également, les deux <em>sysctl</em> suivantes doivent être paramétrées à <em>1</em> :</p>
<pre><span role="presentation">kernel.perf_event_max_sample_rate = 1</span> 
<span role="presentation">kernel.perf_cpu_time_max_percent = 1</span></pre>
<p>Ces deux <em>sysctl</em> servent à gérer combien de ressource et de temps CPU le système de performance peut utiliser. Il s&#39;agit d&#39;un pourcentage (1% du temps CPU). Ces configurations visent à limiter l&#39;impact du sous-système perf sur le système lors de son utilisation. Attention, mettre ces deux <em>sysctl</em> à 0 fait tout simplement sauter toute limite, ce qui serait contre-productif 🙂</p>
<p>Quoi qu&#39;il en soit l&#39;idée derrière le paramétrage de ces deux <em>sysctl</em> est de<strong> limiter l&#39;impact du sous-système perf. sur les performances du système.</strong></p>
<p>Rendez-vous dans le prochain article pour l&#39;étude des durcissement des sysctl réseau :). <strong>N&#39;hésitez pas à signaler toute erreur ou précision technique dans les commentaires 🙂</strong></p>		</div>

			</div>

			<div itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization">
							<div itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject">
					<meta itemprop="url" content="https://www.it-connect.fr/wp-content-itc/uploads/2017/06/IT-Connect_Flat_072017_Small_v2.png"/>
					<meta itemprop="width" content="397"/>
					<meta itemprop="height" content="85"/>
				</div>
				
			<meta itemprop="name" content="IT-Connect"/>
		</div>
				<meta itemprop="dateModified" content="2021-05-12T19:13:22+02:00"/>
		<meta itemscope="" itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/"/>
					<div class="meta_post_image" itemprop="image" itemscope="" itemtype="https://schema.org/ImageObject">
				<meta itemprop="url" content="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-systeme.jpg"/>
				<meta itemprop="width" content="800"/>
				<meta itemprop="height" content="445"/>
			</div>
			</article>

			        	<div class="bloc-partage">
			<span class="text-share">Partagez cet article</span>
                        <a href="https://www.twitter.com/share?text=@ITConnect_fr - Détails des durcissements des sysctl sous Linux : sysctl système&amp;url=https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/" target="_blank" title="Partager sur Twitter">
				<img class="class_rs_share" alt="Partager sur Twitter" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%200%200&#39;%3E%3C/svg%3E" data-lazy-src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_twitter.png"/><noscript><img class="class_rs_share" alt="Partager sur Twitter" src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_twitter.png"/></noscript>
                	</a>
                	<a href="https://www.facebook.com/sharer.php?u=https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/&amp;t=Détails des durcissements des sysctl sous Linux : sysctl système" target="_blank">
                        	<img class="class_rs_share" alt="Partager sur Facebook" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%200%200&#39;%3E%3C/svg%3E" data-lazy-src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_facebook.png"/><noscript><img class="class_rs_share" alt="Partager sur Facebook" src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_facebook.png" /></noscript>
                	</a>
                	<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/&amp;title=Détails des durcissements des sysctl sous Linux : sysctl système" target="_blank">
                        	<img class="class_rs_share" alt="Partager sur Linkedin" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%200%200&#39;%3E%3C/svg%3E" data-lazy-src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_linkedin.png"/><noscript><img class="class_rs_share" alt="Partager sur Linkedin" src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_linkedin.png" /></noscript>
                	</a>
                	<a href="https://plus.google.com/share?url=https://www.it-connect.fr/details-durcissement-sysctl-systeme-linux/" target="_blank">
                        	<img class="class_rs_share" alt="Partager sur Google+" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%200%200&#39;%3E%3C/svg%3E" data-lazy-src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_google.png"/><noscript><img class="class_rs_share" alt="Partager sur Google+" src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_google.png" /></noscript>
                	</a>
                	<a href="/cdn-cgi/l/email-protection#a798d4d2c5cdc2c4d39a87eef38ae4c8c9c9c2c4d3879d87d2c987cbcec2c987cec9d3640ed5c2d4d4c6c9d3878681c6cad79cc5c8c3de9a87e3640ed3c6cecbd487c3c2d487c3d2d5c4ced4d4c2cac2c9d3d487c3c2d487d4ded4c4d3cb87d4c8d2d487ebcec9d2df879d87d4ded4c4d3cb87d4ded4d3640fcac287cfd3d3d7d49d8888d0d0d089ced38ac4c8c9c9c2c4d389c1d588c3c2d3c6cecbd48ac3d2d5c4ced4d4c2cac2c9d38ad4ded4c4d3cb8ad4ded4d3c2cac28acbcec9d2df8881c6cad79cd3ced3cbc29ae3640ed3c6cecbd487c3c2d487c3d2d5c4ced4d4c2cac2c9d3d487c3c2d487d4ded4c4d3cb87d4c8d2d487ebcec9d2df879d87d4ded4c4d3cb87d4ded4d3640fcac289">
                        	<img class="class_rs_share" alt="Envoyer par mail" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%200%200&#39;%3E%3C/svg%3E" data-lazy-src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_email.png"/><noscript><img class="class_rs_share" alt="Envoyer par mail" src="https://www.it-connect.fr/wp-content-itc/themes/itc-2017-child/images/flat_email.png" /></noscript>
                	</a>
        	</div>
		</div><!-- #content -->

		
			<ul class="default-wp-page clearfix thumbnail-pagination">
									<li class="previous">
						<img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-patch-tuesday-mai-2021-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-patch-tuesday-mai-2021-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-patch-tuesday-mai-2021-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-patch-tuesday-mai-2021-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-patch-tuesday-mai-2021-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-patch-tuesday-mai-2021-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript><a href="https://www.it-connect.fr/patch-tuesday-mai-2021-55-vulnerabilites-et-3-failles-zero-day-corrigees/" rel="prev"><span class="meta-nav">← Previous</span> Patch Tuesday – Mai 2021 : 55 vulnérabilités et 3 failles Zero Day corrigées</a>					</li>
				
									<li class="next">
						<a href="https://www.it-connect.fr/details-durcissement-sysctl-reseau-linux/" rel="next">Détails des durcissements des sysctl sous Linux : sysctl réseau <span class="meta-nav">Next →</span></a><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-reseau-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-reseau-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-reseau-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-reseau-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-reseau-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-linux-sysctl-durcissements-sysctl-reseau-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript>					</li>
							</ul>

					
							<div class="author-box">
					<div class="author-img"><img alt="" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20100%20100&#39;%3E%3C/svg%3E" data-lazy-srcset="https://secure.gravatar.com/avatar/f61eee1ad118f37c6a77111e7eb22ced?s=200&amp;d=mm&amp;r=g 2x" class="avatar avatar-100 photo" height="100" width="100" itemprop="image" data-lazy-src="https://secure.gravatar.com/avatar/f61eee1ad118f37c6a77111e7eb22ced?s=100&amp;d=mm&amp;r=g"/><noscript><img alt='' src='https://secure.gravatar.com/avatar/f61eee1ad118f37c6a77111e7eb22ced?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f61eee1ad118f37c6a77111e7eb22ced?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' itemprop="image" /></noscript></div>
					<div class="author-description-wrapper">
						<h4 class="author-name">Mickael Dorigny</h4>

						<p class="author-description">Co-fondateur d&#39;IT-Connect.fr. 
Auditeur en sécurité des systèmes d&#39;information chez Amossys</p>
						
		<ul class="author-social-sites">
			
			
			
			
			
			
			
					</ul>

															<p class="author-url">mickael a publié 509 articles<a href="https://www.it-connect.fr/author/mickael/">Voir toutes les publications de cet auteur</a></p>
											</div>
				</div>

			
			
			
	<div class="related-posts-wrapper style-one">

		<h4 class="related-posts-main-title">
			<i class="fa fa-thumbs-up"></i><span>Vous pourrez aussi aimer</span>
		</h4>

		<div class="related-posts clearfix ">

							<div class="single-related-posts">

											<div class="related-posts-thumbnail">
							<a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/" title="Linux – Afficher la branche Git dans le prompt">
								<img width="390" height="205" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20390%20205&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-390x205.jpg"/><noscript><img width="390" height="205" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-390x205.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" /></noscript>							</a>
						</div>
					
					<div class="article-content">
						<h3 class="entry-title">
							<a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/" rel="bookmark" title="Linux – Afficher la branche Git dans le prompt">
								Linux – Afficher la branche Git dans le prompt							</a>
						</h3><!--/.post-title-->

						<div class="below-entry-meta ">
			<span class="posted-on"><a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/" title="13:00" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2021-05-17T13:00:44+02:00" itemprop="datePublished">17/05/2021</time><time class="updated" datetime="2021-05-16T17:32:55+02:00" itemprop="dateModified">16/05/2021</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n" href="https://www.it-connect.fr/author/thibault-baheux/" title="Thibault Baheux">
						Thibault Baheux					</a>
				</span>
			</span>

			
							<span class="comments">
											<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/#comments" itemprop="discussionURL">1</a>										</span>
				</div>					</div>

				</div><!--/.related-->
							<div class="single-related-posts">

											<div class="related-posts-thumbnail">
							<a href="https://www.it-connect.fr/les-connexions-sockets-avec-la-commande-ss/" title="Les connexions sockets avec la commande ss">
								<img width="390" height="205" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20390%20205&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-design-06-390x205.jpg"/><noscript><img width="390" height="205" src="https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-design-06-390x205.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" /></noscript>							</a>
						</div>
					
					<div class="article-content">
						<h3 class="entry-title">
							<a href="https://www.it-connect.fr/les-connexions-sockets-avec-la-commande-ss/" rel="bookmark" title="Les connexions sockets avec la commande ss">
								Les connexions sockets avec la commande ss							</a>
						</h3><!--/.post-title-->

						<div class="below-entry-meta ">
			<span class="posted-on"><a href="https://www.it-connect.fr/les-connexions-sockets-avec-la-commande-ss/" title="09:45" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2017-07-11T09:45:36+02:00" itemprop="datePublished">11/07/2017</time><time class="updated" datetime="2017-07-02T14:47:28+02:00" itemprop="dateModified">02/07/2017</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n" href="https://www.it-connect.fr/author/philippe-pierre/" title="Philippe PIERRE">
						Philippe PIERRE					</a>
				</span>
			</span>

			
							<span class="comments">
											<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/les-connexions-sockets-avec-la-commande-ss/#comments" itemprop="discussionURL">2</a>										</span>
				</div>					</div>

				</div><!--/.related-->
							<div class="single-related-posts">

											<div class="related-posts-thumbnail">
							<a href="https://www.it-connect.fr/lamp-security-5-solution-et-explications/" title="Lamp Security 5 : Solution et explications">
								<img width="230" height="205" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20230%20205&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2013/12/LampSec.png 280w, https://www.it-connect.fr/wp-content-itc/uploads/2013/12/LampSec-160x142.png 160w" data-lazy-sizes="(max-width: 230px) 100vw, 230px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2013/12/LampSec.png"/><noscript><img width="230" height="205" src="https://www.it-connect.fr/wp-content-itc/uploads/2013/12/LampSec.png" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2013/12/LampSec.png 280w, https://www.it-connect.fr/wp-content-itc/uploads/2013/12/LampSec-160x142.png 160w" sizes="(max-width: 230px) 100vw, 230px" /></noscript>							</a>
						</div>
					
					<div class="article-content">
						<h3 class="entry-title">
							<a href="https://www.it-connect.fr/lamp-security-5-solution-et-explications/" rel="bookmark" title="Lamp Security 5 : Solution et explications">
								Lamp Security 5 : Solution et explications							</a>
						</h3><!--/.post-title-->

						<div class="below-entry-meta ">
			<span class="posted-on"><a href="https://www.it-connect.fr/lamp-security-5-solution-et-explications/" title="09:10" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2013-12-05T09:10:57+02:00" itemprop="datePublished">05/12/2013</time><time class="updated" datetime="2020-01-20T20:24:27+02:00" itemprop="dateModified">20/01/2020</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n" href="https://www.it-connect.fr/author/mickael/" title="Mickael Dorigny">
						Mickael Dorigny					</a>
				</span>
			</span>

			
							<span class="comments">
											<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/lamp-security-5-solution-et-explications/#comments" itemprop="discussionURL">1</a>										</span>
				</div>					</div>

				</div><!--/.related-->
			
		</div><!--/.post-related-->

	</div>

			
		
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Laisser un commentaire <small><a rel="nofollow" id="cancel-comment-reply-link" href="/details-durcissement-sysctl-systeme-linux/#respond" style="display:none;">Annuler la réponse</a></small></h3><form action="https://www.it-connect.fr/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate=""><p class="comment-notes"><span id="email-notes">Votre adresse e-mail ne sera pas publiée.</span> Les champs obligatoires sont indiqués avec <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Commentaire</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Nom <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required"/></p>
<p class="comment-form-email"><label for="email">E-mail <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required"/></p>
<p class="comment-form-url"><label for="url">Site web</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200"/></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"/> <label for="wp-comment-cookies-consent">Enregistrer mon nom, mon e-mail et mon site dans le navigateur pour mon prochain commentaire.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Laisser un commentaire"/> <input type="hidden" name="comment_post_ID" value="42305" id="comment_post_ID"/>
<input type="hidden" name="comment_parent" id="comment_parent" value="0"/>
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="be36e11468"/></p><div class="g-recaptcha" data-sitekey="6LckZPwSAAAAAMdtY0a8X-MPn_2KxrM8LVw9pgDT" data-theme="standard"></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=fr"></script>            <div id="recaptcha-submit-btn-area"> </div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript><input type="hidden" id="ak_js" name="ak_js" value="197"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">Ce site utilise Akismet pour réduire les indésirables. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">En savoir plus sur comment les données de vos commentaires sont utilisées</a>.</p>
</div><!-- #comments -->

	</div><!-- #primary -->

	
<div id="secondary" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	
	<aside id="text-47" class="widget widget_text clearfix">			<div class="textwidget"><p><a href="https://ovh.commander1.com/c3/?tcs=3810&amp;chn=affiliation&amp;src=partnership&amp;cty=FR&amp;site_domain=https://www.ovh.com/fr/&amp;cmp=infra-itconnect&amp;crtive=infra-display-itconnect&amp;url=https://www.ovh.com/fr/serveurs_dedies/infra/?xtor=AL-18-[infra-itconnect]-[infra-display-itconnect]" target="_blank" rel="nofollow noopener"><img class="aligncenter size-full wp-image-27891" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20300%20250&#39;%3E%3C/svg%3E" alt="" width="300" height="250" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2019/10/Infrastructure_300x250_FR.gif"/><noscript><img class="aligncenter size-full wp-image-27891" src="https://www.it-connect.fr/wp-content-itc/uploads/2019/10/Infrastructure_300x250_FR.gif" alt="" width="300" height="250" /></noscript></a></p>
</div>
		</aside><aside id="text-49" class="widget widget_text clearfix">			<div class="textwidget"><div id="impactify-screen-inline"></div>
<p><script>
window.impactifyTag = window.impactifyTag || [];
impactifyTag.push({
    "appId": "it-connect.fr",
    "format": "screen",
    "style": "inline",
    "onNoAd": function(){}
});
(function(d, s, id) {
    var js, ijs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = 'https://ad.impactify.io/static/ad/tag.js';
    ijs.parentNode.insertBefore(js, ijs);
}(document, 'script', 'impactify-sdk'));
</script></p>
</div>
		</aside><aside id="colormag_featured_posts_vertical_widget-2" class="widget widget_featured_posts widget_featured_posts_vertical widget_featured_meta clearfix">
		<h3 class="widget-title"><span>A la une</span></h3><div class="first-post">
			<div class="single-article clearfix">
				<figure><a href="https://www.it-connect.fr/fragattacks-des-failles-wifi-qui-menacent-des-millions-dappareils/" title="FragAttacks : des failles WiFi qui menacent des millions d’appareils !"><img width="390" height="205" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20390%20205&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="FragAttacks : des failles WiFi qui menacent des millions d’appareils !" title="FragAttacks : des failles WiFi qui menacent des millions d’appareils !" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-wifi-fragattacks-2021-390x205.jpg"/><noscript><img width="390" height="205" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-wifi-fragattacks-2021-390x205.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="FragAttacks : des failles WiFi qui menacent des millions d&rsquo;appareils !" title="FragAttacks : des failles WiFi qui menacent des millions d&rsquo;appareils !" /></noscript></a></figure>
				<div class="article-content">
					<div class="above-entry-meta"><span class="cat-links"><a href="https://www.it-connect.fr/actualites/actu-securite/" style="background:#dd0000" rel="category tag">Sécurité</a> </span></div>		<h3 class="entry-title">
			<a href="https://www.it-connect.fr/fragattacks-des-failles-wifi-qui-menacent-des-millions-dappareils/" title="FragAttacks : des failles WiFi qui menacent des millions d’appareils !">
				FragAttacks : des failles WiFi qui menacent des millions d’appareils !			</a>
		</h3>
		<div class="below-entry-meta "><span class="posted-on"><a href="https://www.it-connect.fr/fragattacks-des-failles-wifi-qui-menacent-des-millions-dappareils/" title="09:09" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2021-05-18T09:09:57+02:00">18/05/2021</time></a></span>
		<span class="byline">
			<span class="author vcard">
				<i class="fa fa-user"></i>
				<a class="url fn n" href="https://www.it-connect.fr/author/florian/" title="Florian Burnel">
					Florian Burnel				</a>
			</span>
		</span>

					<span class="comments">
				<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/fragattacks-des-failles-wifi-qui-menacent-des-millions-dappareils/#respond" itemprop="discussionURL">0</a>			</span>
		
		</div>
											<div class="entry-content">
							<p>De millions d’appareils se retrouvent vulnérables à des failles de sécurité liées au Wi-Fi et qui touchent tous les protocoles, autant le WEP que le WPA3.</p>
						</div>
									</div>
			</div>

			</div><div class="following-post">
			<div class="single-article clearfix">
				<figure><a href="https://www.it-connect.fr/windows-un-exploit-existe-pour-la-faille-wormable-situee-dans-le-pilote-http-sys/" title="Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys" title="Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-windows-CVE-2021-31166-exploit-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-windows-CVE-2021-31166-exploit-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-windows-CVE-2021-31166-exploit-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-windows-CVE-2021-31166-exploit-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys" title="Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-windows-CVE-2021-31166-exploit-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-microsoft-windows-CVE-2021-31166-exploit-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>
				<div class="article-content">
					<div class="above-entry-meta"><span class="cat-links"><a href="https://www.it-connect.fr/actualites/actu-securite/" style="background:#dd0000" rel="category tag">Sécurité</a> </span></div>		<h3 class="entry-title">
			<a href="https://www.it-connect.fr/windows-un-exploit-existe-pour-la-faille-wormable-situee-dans-le-pilote-http-sys/" title="Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys">
				Windows : un exploit existe pour la faille wormable située dans le pilote HTTP.sys			</a>
		</h3>
		<div class="below-entry-meta "><span class="posted-on"><a href="https://www.it-connect.fr/windows-un-exploit-existe-pour-la-faille-wormable-situee-dans-le-pilote-http-sys/" title="08:20" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2021-05-18T08:20:44+02:00">18/05/2021</time></a></span>
		<span class="byline">
			<span class="author vcard">
				<i class="fa fa-user"></i>
				<a class="url fn n" href="https://www.it-connect.fr/author/florian/" title="Florian Burnel">
					Florian Burnel				</a>
			</span>
		</span>

					<span class="comments">
				<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/windows-un-exploit-existe-pour-la-faille-wormable-situee-dans-le-pilote-http-sys/#respond" itemprop="discussionURL">0</a>			</span>
		
		</div>
									</div>
			</div>

			
			<div class="single-article clearfix">
				<figure><a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/" title="Linux – Afficher la branche Git dans le prompt"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Linux – Afficher la branche Git dans le prompt" title="Linux – Afficher la branche Git dans le prompt" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Linux &#8211; Afficher la branche Git dans le prompt" title="Linux &#8211; Afficher la branche Git dans le prompt" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/04/slide-git-linux-comment-afficher-branche-git-prompt-linux-2021-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>
				<div class="article-content">
					<div class="above-entry-meta"><span class="cat-links"><a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/scripting/bash/" rel="category tag">Bash</a> <a href="https://www.it-connect.fr/cours-tutoriels/administration-systemes/linux/linux-systeme/" rel="category tag">Commandes et Système</a> </span></div>		<h3 class="entry-title">
			<a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/" title="Linux – Afficher la branche Git dans le prompt">
				Linux – Afficher la branche Git dans le prompt			</a>
		</h3>
		<div class="below-entry-meta "><span class="posted-on"><a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/" title="13:00" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2021-05-17T13:00:44+02:00">17/05/2021</time><time class="updated" datetime="2021-05-16T17:32:55+02:00">16/05/2021</time></a></span>
		<span class="byline">
			<span class="author vcard">
				<i class="fa fa-user"></i>
				<a class="url fn n" href="https://www.it-connect.fr/author/thibault-baheux/" title="Thibault Baheux">
					Thibault Baheux				</a>
			</span>
		</span>

					<span class="comments">
				<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/linux-afficher-la-branche-git-dans-le-prompt/#comments" itemprop="discussionURL">1</a>			</span>
		
		</div>
									</div>
			</div>

			
			<div class="single-article clearfix">
				<figure><a href="https://www.it-connect.fr/kmeet-lalternative-europeenne-et-ecologique-a-zoom-et-teams/" title="kMeet : l’alternative européenne et écologique à Zoom et Teams"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="kMeet : l’alternative européenne et écologique à Zoom et Teams" title="kMeet : l’alternative européenne et écologique à Zoom et Teams" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-kmeet-2021-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-kmeet-2021-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-kmeet-2021-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-kmeet-2021-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="kMeet : l&rsquo;alternative européenne et écologique à Zoom et Teams" title="kMeet : l&rsquo;alternative européenne et écologique à Zoom et Teams" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-kmeet-2021-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-kmeet-2021-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>
				<div class="article-content">
					<div class="above-entry-meta"><span class="cat-links"><a href="https://www.it-connect.fr/actualites/entreprise/" rel="category tag">Entreprise</a> <a href="https://www.it-connect.fr/actualites/actu-logiciel-os/" rel="category tag">Logiciel - OS</a> </span></div>		<h3 class="entry-title">
			<a href="https://www.it-connect.fr/kmeet-lalternative-europeenne-et-ecologique-a-zoom-et-teams/" title="kMeet : l’alternative européenne et écologique à Zoom et Teams">
				kMeet : l’alternative européenne et écologique à Zoom et Teams			</a>
		</h3>
		<div class="below-entry-meta "><span class="posted-on"><a href="https://www.it-connect.fr/kmeet-lalternative-europeenne-et-ecologique-a-zoom-et-teams/" title="10:00" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2021-05-17T10:00:13+02:00">17/05/2021</time><time class="updated" datetime="2021-05-16T17:33:06+02:00">16/05/2021</time></a></span>
		<span class="byline">
			<span class="author vcard">
				<i class="fa fa-user"></i>
				<a class="url fn n" href="https://www.it-connect.fr/author/florian/" title="Florian Burnel">
					Florian Burnel				</a>
			</span>
		</span>

					<span class="comments">
				<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/kmeet-lalternative-europeenne-et-ecologique-a-zoom-et-teams/#respond" itemprop="discussionURL">0</a>			</span>
		
		</div>
									</div>
			</div>

			
			<div class="single-article clearfix">
				<figure><a href="https://www.it-connect.fr/le-ransomware-echoraix-sattaque-activement-aux-nas-qnap/" title="Le ransomware eChoraix s’attaque activement aux NAS QNAP"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Le ransomware eChoraix s’attaque activement aux NAS QNAP" title="Le ransomware eChoraix s’attaque activement aux NAS QNAP" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-qnap-echoraix-2021-05-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-qnap-echoraix-2021-05-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-qnap-echoraix-2021-05-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-qnap-echoraix-2021-05-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Le ransomware eChoraix s&rsquo;attaque activement aux NAS QNAP" title="Le ransomware eChoraix s&rsquo;attaque activement aux NAS QNAP" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-qnap-echoraix-2021-05-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2021/05/slide-qnap-echoraix-2021-05-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>
				<div class="article-content">
					<div class="above-entry-meta"><span class="cat-links"><a href="https://www.it-connect.fr/actualites/actu-securite/" style="background:#dd0000" rel="category tag">Sécurité</a> </span></div>		<h3 class="entry-title">
			<a href="https://www.it-connect.fr/le-ransomware-echoraix-sattaque-activement-aux-nas-qnap/" title="Le ransomware eChoraix s’attaque activement aux NAS QNAP">
				Le ransomware eChoraix s’attaque activement aux NAS QNAP			</a>
		</h3>
		<div class="below-entry-meta "><span class="posted-on"><a href="https://www.it-connect.fr/le-ransomware-echoraix-sattaque-activement-aux-nas-qnap/" title="09:48" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2021-05-17T09:48:20+02:00">17/05/2021</time></a></span>
		<span class="byline">
			<span class="author vcard">
				<i class="fa fa-user"></i>
				<a class="url fn n" href="https://www.it-connect.fr/author/florian/" title="Florian Burnel">
					Florian Burnel				</a>
			</span>
		</span>

					<span class="comments">
				<i class="fa fa-comment"></i><a href="https://www.it-connect.fr/le-ransomware-echoraix-sattaque-activement-aux-nas-qnap/#respond" itemprop="discussionURL">0</a>			</span>
		
		</div>
									</div>
			</div>

			</div></aside><aside id="itc_random_cours_widgdet-2" class="widget widget_random_post_colormag widget_featured_posts clearfix">
		<div class="random-posts-widget">
							<h3 class="widget-title"><span>Découvrez nos cours</span></h3>			<div class="random_posts_widget_inner_wrap">
									<div class="single-article clearfix">
						<figure class="random-images"><a href="https://www.it-connect.fr/cours/debuter-avec-kali-linux/" title="Débuter avec Kali Linux"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Débuter avec Kali Linux" title="Débuter avec Kali Linux" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2020/01/slide-kali-linux-cours-home-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2020/01/slide-kali-linux-cours-home-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2020/01/slide-kali-linux-cours-home-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2020/01/slide-kali-linux-cours-home-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Débuter avec Kali Linux" title="Débuter avec Kali Linux" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2020/01/slide-kali-linux-cours-home-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2020/01/slide-kali-linux-cours-home-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>						<div class="article-content">
							<h3 class="entry-title-courses">
								<a href="https://www.it-connect.fr/cours/debuter-avec-kali-linux/" title="Débuter avec Kali Linux">Débuter avec Kali Linux</a>
							</h3>
						</div>

					</div>
									<div class="single-article clearfix">
						<figure class="random-images"><a href="https://www.it-connect.fr/cours/debuter-avec-les-strategies-de-groupe-sous-windows-server/" title="Débuter avec les stratégies de groupe sous Windows Server"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Débuter avec les stratégies de groupe sous Windows Server" title="Débuter avec les stratégies de groupe sous Windows Server" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2019/12/slide-cours-strategies-de-groupe-v1-130x90.png 130w, https://www.it-connect.fr/wp-content-itc/uploads/2019/12/slide-cours-strategies-de-groupe-v1-392x272.png 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2019/12/slide-cours-strategies-de-groupe-v1-130x90.png"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2019/12/slide-cours-strategies-de-groupe-v1-130x90.png" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Débuter avec les stratégies de groupe sous Windows Server" title="Débuter avec les stratégies de groupe sous Windows Server" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2019/12/slide-cours-strategies-de-groupe-v1-130x90.png 130w, https://www.it-connect.fr/wp-content-itc/uploads/2019/12/slide-cours-strategies-de-groupe-v1-392x272.png 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>						<div class="article-content">
							<h3 class="entry-title-courses">
								<a href="https://www.it-connect.fr/cours/debuter-avec-les-strategies-de-groupe-sous-windows-server/" title="Débuter avec les stratégies de groupe sous Windows Server">Débuter avec les stratégies de groupe sous Windows Server</a>
							</h3>
						</div>

					</div>
									<div class="single-article clearfix">
						<figure class="random-images"><a href="https://www.it-connect.fr/cours/comment-installer-system-center-configuration-manager/" title="Comment installer System Center Configuration Manager ?"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20130%2090&#39;%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Comment installer System Center Configuration Manager ?" title="Comment installer System Center Configuration Manager ?" data-lazy-srcset="https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-sccm-home-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-sccm-home-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-sccm-home-130x90.jpg"/><noscript><img width="130" height="90" src="https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-sccm-home-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Comment installer System Center Configuration Manager ?" title="Comment installer System Center Configuration Manager ?" srcset="https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-sccm-home-130x90.jpg 130w, https://www.it-connect.fr/wp-content-itc/uploads/2017/07/slide-sccm-home-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure>						<div class="article-content">
							<h3 class="entry-title-courses">
								<a href="https://www.it-connect.fr/cours/comment-installer-system-center-configuration-manager/" title="Comment installer System Center Configuration Manager ?">Comment installer System Center Configuration Manager ?</a>
							</h3>
						</div>

					</div>
								</div>
			</div>
		</aside>
	</div>

	
		</div><!-- .inner-wrap -->
				</div><!-- #main -->
				<footer id="colophon" class="clearfix  " role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		
<div class="footer-widgets-wrapper">
	<div class="inner-wrap">
		<div class="footer-widgets-area clearfix">
			<div class="tg-upper-footer-widgets clearfix">
				<div class="footer_upper_widget_area tg-one-third">
									</div>
				<div class="footer_upper_widget_area tg-one-third">
									</div>
				<div class="footer_upper_widget_area tg-one-third tg-one-third-last">
									</div>
			</div>

			<div class="tg-footer-main-widget">
				<div class="tg-first-footer-widget">
					<aside id="search-8" class="widget widget_search clearfix"><h3 class="widget-title"><span>Vous cherchez quelque chose ?</span></h3>
<form action="https://www.it-connect.fr/" class="search-form searchform clearfix" method="get" role="search">

	<div class="search-wrap">
		<input type="search" class="s field" name="s" value="" placeholder="Recherche"/>

		<button class="search-icon" type="submit"></button>
	</div>

</form><!-- .searchform -->
</aside>				</div>
			</div>

			<div class="tg-footer-other-widgets">
				<div class="tg-second-footer-widget">
					<aside id="pages-2" class="widget widget_pages clearfix"><h3 class="widget-title"><span>Découvrir IT-Connect</span></h3>
			<ul>
				<li class="page_item page-item-2"><a href="https://www.it-connect.fr/a-propos/">A propos</a></li>
<li class="page_item page-item-6097"><a href="https://www.it-connect.fr/rejoignez-nous/">Comment contribuer sur IT-Connect ?</a></li>
<li class="page_item page-item-2293"><a href="https://www.it-connect.fr/contact/">Contact</a></li>
<li class="page_item page-item-5483"><a href="https://www.it-connect.fr/espace-annonceurs/">Espace annonceurs</a></li>
<li class="page_item page-item-4535"><a href="https://www.it-connect.fr/lequipe/">L’Equipe</a></li>
<li class="page_item page-item-20750"><a href="https://www.it-connect.fr/offres-demploi/">Offres d’emploi</a></li>
<li class="page_item page-item-27984"><a href="https://www.it-connect.fr/politique-de-confidentialite/">Politique de confidentialité</a></li>
<li class="page_item page-item-18256"><a href="https://www.it-connect.fr/soutenir-it-connect/">Soutenir IT-Connect</a></li>
			</ul>

			</aside>				</div>
				<div class="tg-third-footer-widget">
					<aside id="meta-2" class="widget widget_meta clearfix"><h3 class="widget-title"><span>Espace personnel</span></h3>
		<ul>
			<li><a href="https://www.it-connect.fr/wp-login.php?action=register">Inscription</a></li>			<li><a href="https://www.it-connect.fr/wp-login.php">Connexion</a></li>
			<li><a href="https://www.it-connect.fr/feed/">Flux des publications</a></li>
			<li><a href="https://www.it-connect.fr/comments/feed/">Flux des commentaires</a></li>

			<li><a href="https://fr.wordpress.org/">Site de WordPress-FR</a></li>
		</ul>

		</aside>				</div>
				<div class="tg-fourth-footer-widget">
					<aside id="text-45" class="widget widget_text clearfix"><h3 class="widget-title"><span>Recommandations</span></h3>			<div class="textwidget"><p><a title="Blog Informatique Libre et Indépendant" href="http://blogmotion.fr" target="_blank" rel="nofollow noopener"> Blogmotion </a><br/>
<a title="Conseil Informatique Normandie" href="https://www.deliberata.com/" target="_blank" rel="nofollow noopener"> Délibérata </a><br/>
<a title="Tech2Tech" href="https://www.tech2tech.fr/" target="_blank" rel="noopener"> Tech2tech </a></p>
</div>
		</aside>				</div>
			</div>

			<div class="footer-full-width-sidebar inner-wrap clearfix">
							</div>
		</div>
	</div>
</div>
		<div class="footer-socket-wrapper clearfix">
			<div class="inner-wrap">
				<div class="footer-socket-area">
		
		<div class="footer-socket-right-section">
			
		<div class="social-links clearfix">
			<ul>
				<li><a href="https://www.facebook.com/it.connect.fr/" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/ITConnect_fr" target="_blank"><i class="fa fa-twitter"></i></a></li><li><a href="https://www.instagram.com/it_connect.fr/?hl=fr" target="_blank"><i class="fa fa-instagram"></i></a></li><li><a href="https://www.youtube.com/channel/UCIJTq0nGrgkGMy1xJL_YppQ" target="_blank"><i class="fa fa-youtube"></i></a></li><li><a href="https://www.linkedin.com/company/it-connect-fr" target="_blank"><i class="fa fa-linkedin"></i></a></li>			</ul>
		</div><!-- .social-links -->
		
			<nav class="footer-menu clearfix">
							</nav>
		</div>

				<div class="footer-socket-left-section">
			<div class="copyright">IT-Connect - Copyright © 2021 | Creative Commons License BY-NC-ND 4.0</div>		</div>
				</div><!-- .footer-socket-area -->
					</div><!-- .inner-wrap -->
		</div><!-- .footer-socket-wrapper -->
				</footer><!-- #colophon -->
					<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>
						<div class="reading-progress-bar"></div>
					</div><!-- #page -->
		            



<script type="text/javascript" id="rocket-browser-checker-js-after">
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type="text/javascript" id="rocket-delay-js-js-after">
(function() {
"use strict";var e=function(){function n(e,t){for(var r=0;r<t.length;r++){var n=t[r];n.enumerable=n.enumerable||!1,n.configurable=!0,"value"in n&&(n.writable=!0),Object.defineProperty(e,n.key,n)}}return function(e,t,r){return t&&n(e.prototype,t),r&&n(e,r),e}}();function n(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function r(e,t){n(this,r),this.attrName="data-rocketlazyloadscript",this.browser=t,this.options=this.browser.options,this.triggerEvents=e,this.userEventListener=this.triggerListener.bind(this)}return e(r,[{key:"init",value:function(){this._addEventListener(this)}},{key:"reset",value:function(){this._removeEventListener(this)}},{key:"_addEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.addEventListener(e,t.userEventListener,t.options)})}},{key:"_removeEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.removeEventListener(e,t.userEventListener,t.options)})}},{key:"_loadScriptSrc",value:function(){var r=this,e=document.querySelectorAll("script["+this.attrName+"]");0!==e.length&&Array.prototype.slice.call(e).forEach(function(e){var t=e.getAttribute(r.attrName);e.setAttribute("src",t),e.removeAttribute(r.attrName)}),this.reset()}},{key:"triggerListener",value:function(){this._loadScriptSrc(),this._removeEventListener(this)}}],[{key:"run",value:function(){RocketBrowserCompatibilityChecker&&new r(["keydown","mouseover","touchmove","touchstart","wheel"],new RocketBrowserCompatibilityChecker({passive:!0})).init()}}]),r}();t.run();
}());
</script>








<script type="text/javascript" id="colormag-custom-js-extra">
/* <![CDATA[ */
var colormag_progress_bar_bgcolor = {"bg_color":"#222222"};
var colormag_load_more = {"tg_nonce":"8e7f2f889a","ajax_url":"https:\/\/www.it-connect.fr\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>








<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async="" src="https://www.it-connect.fr/wp-content-itc/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script src="https://www.it-connect.fr/wp-content-itc/cache/min/1/aed2c5cdbd930a5a458b2dbdeb5be37b.js" data-minify="1"></script>


<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="it_connect_fr",_audins_did=122228;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.it_connect_fr,DomainId.122228" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html><!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->