Multiples vulnérabilités dans Wireshark

L'analyseur de paquets Wireshark contient de multiples vulnérabilités, plusieurs tickets de sécurité ont été publiés sur le site du logiciel. Elles sont désormais corrigées, c'est pour cela que je vous recommande de mettre à jour l'application vers une version plus sécurisée. Principalement, elles permettaient de provoquer un déni de service et une exécution de code arbitraire.

logo-wireshark

  • wnpa-sec-2013-60 : G. Geshev a découvert que l'analyseur "Netmon" pouvait planter, ce qui fait qu'il est possible de planter Wireshark en faisant lire un paquet de données mal formés. Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que les versions 1.10.2 et 1.8.10 sont fixées.
  • wnpa-sec-2013-59 : Le "Dissector LDAP" peut se bloquer si l'on lui fait lire un paquet mal formé. Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que les versions 1.10.2 et 1.8.10 sont fixées.
  • wnpa-sec-2013-58 : Le "Dissector MQ" peut se bloquer si l'on lui fait lire un paquet mal formé. Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que les versions 1.10.2 et 1.8.10 sont fixées.
  • wnpa-sec-2013-57 : Ben Schmidt a découvert que le "Dissector RTPS" pouvait faire un dépassement de mémoire (buffer overflow). Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que les versions 1.10.2 et 1.8.10 sont fixées.
  • wnpa-sec-2013-56 : Ben Schmidt a aussi découvert la possibilité de créer une boucle infinie grâce à la lecture d'un paquet mal formé, ce qui provoque une consommation excessive de CPU et peut mener à un déni de service. Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que les versions 1.10.2 et 1.8.10 sont fixées.
  • wnpa-sec-2013-55 : Laurent Butti a découvert la possibilité de planter le "Dissector NBAP". Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que les versions 1.10.2 et 1.8.9 sont fixées.
  • wnpa-sec-2013-54 : Laurent Butti a également découvert la possibilité de planter "Bluetooth HCI ACL". Les versions 1.10.0 à 1.10.1 et 1.8.0 à 1.8.9 sont affectées, alors que la version 1.10.2 est fixées.

 

Source : Wireshark Security

Partagez cet article Partager sur Twitter Partager sur Facebook Partager sur Linkedin Partager sur Google+ Envoyer par mail

Florian Burnel

Ingénieur système et réseau et cofondateur d'IT-Connect. Je souhaite partager mon expérience et mes découvertes au travers de mes articles. Généraliste avec une attirance particulière pour les solutions Microsoft et le scripting. Bonne lecture.

florian a publié 3119 articlesVoir toutes les publications de cet auteur

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

 

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.